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Chapter   1

INTRODUCTION

What HPGL is
HPGL is the language used to control Hewlett Packard pen

plotters. HPGL commands control the path of the pen across the
surface of the paper and tell the plotter when the pen is to be
extended down onto the paper and when it is to be retracted.
HPGL also commands pen changes to accommodate varying line
thicknesses or different colors.

HPGL is popular among automated engravers and routers. It
is a natural choice for a low cost machine tool control language,
mainly because there exists a wealth of powerful and low cost
drawing and drafting programs which are capable of communicat-
ing to Hewlett Packard plotters. With minor adaptation, and the
use of the HPGL Controller, these drawing and drafting pro-
grams can be used as powerful tool path generators.

What the HPGL Controller is
The HPGL Controller uses the commands contained in the

HPGL plot file to control motors for milling, routing, engraving,
plasma cutting, water jet cutting, laser etching, glue despensing,
flame cutting, large scale template plotting, or other operations
where the motion of a tool must be directed over a specified path.
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The HPGL Controller program also provides a convenient
operator interface and includes features especially useful in man-
aging production operations. Pop-up menus and easy-to-use man-
ual positioning options allow the operator to conveniently position
the tool for each job set-up.

Tool programming is quickly stored and retrieved for each
job. Software setups for each job include tool position, plot file,
tool changes, cutting speeds, etc. Setup values are entered via dia-
log boxes, and can also be easily duplicated, modified, and stored
for later use.

What Kind of Machine is Controlled
The machine which is being controlled consists of three

translation stages. Two of the stages (X and Y axes) are controlled
by means of stepper motors (or step/direction controlled servos).
The third stage (Z axis) can be either a step motor controlled
stage (allowing it to plunge to varying depths), or it may be a sim-
ple solenoid actuated up/down control, such as is found in a plot-
ter or an engraver. The output control signals are generated by
means of the Ability Systems Indexer LPT device driver.

How the Machine is Controlled
The path of the tool can be defined by means of a CAD pro-

gram, such as AutoCAD, DesignCAD, RoboCAD, Generic CAD,
AutoSketch, Designer, CorelDRAW, or virtually any program
which is capable of communicating to a Hewlett Packard
plotter.The tool path is drawn using the CAD program. By direct-
ing the pen plot output to a file instead of the plotter, the tool path
is stored on a diskette, disk, or network drive. The plot file, along
with other setup information, is used by the HPGL Controller to
control manufacturing operations. Last minute information partic-
ular to the manufacturing operation, such as tool path order and
trace width (tool radius) offset compensation, is added by means
of a built in Tool Path Editor. The job set-up information is put
into action in the HPGL Controller’s Production Menu. Using
positioning options or joystick control, the operator manipulates
the stages to the desired starting position and then selects auto-
matic operation from the menu. The machine tool then traverses
the defined paths in the manner determined by the set-ups.
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Who Uses the HPGL Controller
The HPGL Controller is a design engineers tool. It provides

a powerful and convenient operator interface for OEMs and
machine tool retrofitters. It does not require computer program-
ming knowledge. It does require a working knowledge of Indexer
LPT and a knowledge of machine design. Since this product can
be used on machines varying from specialized plotters to cutting
tools, the depth of knowledge required will depend on the com-
plexity of the design. Safety should be your primary concern. Due
to the complex nature of software in general, safety features must
be designed into machine wiring and mechanical hardware.

WARNING
ALWAYS PLAN FOR THE UNEXPECTED WHEN USING
SOFTWARE! If you cannot build appropriate safety features
into your hardware by virtue of cost, expertise or any other rea-
son, you should not be using this product!

How to Use this Manual
This manual is an engineer’s guide to implementing the

HPGL Controller. Here you will find information about design-
ing specialized machinery which requires tool path control. This
text presumes that the reader has a working knowledge of the
Indexer LPT
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Chapter 2

CAD/CAM BASICS

Geometric Entities
The acronym “CAD” stands for “Computer Aided Design”.

Programs such as AutoCAD by Auto Desk, Design CAD by
American Small Business Computers, and Sketchpad by Robo
Systems are considered CAD programs. CAD programs range in
price from under a hundred dollars to several thousand dollars.
They are usually priced according to sophistication and ease of
use. Drawing programs such as Corel Draw and Designer can
also be considered CAD programs. Essentially, CAD programs
provide a convenient means for generating drawings using the
computer, saving these drawings in electronic form, and produc-
ing paper output of the drawings using a printer or plotter. CAD
programs usually contain other features helpful in manufacturing
documentation, but the features which are most applicable to the
HPGL Controller are the generation of drawings and the means
of physically representing these drawings on paper.

The acronym “CAM” stands for “Computer Aided
Manufacturing.” The term “CAM” is broadly applied to any
process where computers interact with the manufacturing process.
In our immediate application, a computer is being used to manip-
ulate the path of a tool. The HPGL Controller is a CAM pro-
gram in the strictest sense of the word.
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When a drawing is created by means of a CAD program, the
component parts of the drawing, such as lines, circles, and arcs,
are stored in data objects called “entities.” Entities describe geo-
metric properties, size, and location. When a CAD program stores
the representation of a drawing in a disk file, it saves a collection
of entities. When a CAD program retrieves the drawing from the
file, it reads the data in the entities and visually represents on the
computer screen the geometries described by the entities. CAD
programs store and retrieve data in a format which is best suited
for the purposes of generating and editing a screen image.

Plotting a Drawing
When a CAD program plots a drawing, it is in a sense per-

forming a CAM operation. The CAD program assists the plotter
in manufacturing a paper copy representation of the drawing. The
pen plotter responds to commands which it receives from the
computer. These commands describe the geometric entities of the
drawing. The commands appear in a format which is best suited
for plotting operations.

The most commonly used data format for plotting is Hewlett
Packard Graphics Language, or HPGL. HPGL is an ASCII lan-
guage designed specifically to control pen movement. It is usually
transmitted from the computer to the plotter over an RS-232 serial
communications line. Most CAD programs allow the user to plot
directly from within the program or to store the plotting informa-
tion in an ASCII disk file (“Plot File”). The Plot File contains the
sequence of HPGL commands. 

You may view the contents of the Plot File from a DOS
prompt by TYPE’ing the file to the screen. However, since most
HPGL files typically do not contain carriage return or line feed
control characters, the file can only be viewed and edited by file
browsers or text editors with special capabilities. In this manual
we refer to the Plot File and HPGL File synonomously.

Post-Processing
The Plot File contains commands understood by the plotter’s

motion control system. Since these commands describe a geomet-
ric path, it is possible to interpret these commands in such a way
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as to construct a new set of commands (describing essentially the
same path) which is understood by a different motion control sys-
tem. This procedure is called post-processing. A “post-processor”
is a program or sub-routine which converts one set of commands
to another, much the same as interpreting a spoken language. The
objective in interpreting a foreign language is to express the con-
cepts spoken in one culture in words which another culture can
understand. In post-processing, geometry which is described in
one language (in this case, HPGL) is converted into commands
which the machine’s motion controls (in this case, Indexer LPT)
can understand.

Beyond Post-Processing
The HPGL Controller software is more than a post-proces-

sor, however, since it combines features of a machine controller
front panel, file manager, and post processor into a simple menu
driven interface. The HPGL Controller can also convert features
present in HPGL to purposes which are useful in specialized
machine tool control. For example, HPGL uses the “SP” (Select
Pen) command to change pens for purposes of color or line width.
The HPGL Controller allows you to optionally change tools
with each pen change. In addition, it allows you to re-define the
tool plunge for different depths (optionally in three axis configu-
rations). You may also specify special machine control operations,
such as turning on a spindle or coolant at selected times in the
manufacturing operation.
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Chapter 3

IMPORTANT FILES

The HPGL Controller Program
The file name of the HPGL Controller program is

HPIXW.EXE. It is run by snapping over its icon from the
Windows Start > Programs menu.

The Indexer LPT Device Driver
The HPGL Controller communicates directly with the

Indexer LPT motion control software and takes advantage of
many of its advanced features. Indexer LPT is a Windows device
driver which is accessed by the HPGL Controller. All manipula-
tion of control signals is accomplished through the Indexer LPT
device driver. Refer to the Indexer LPT manual for instructions
on the proper installation of this software, and for effective use of
its many unique features.

The System Configuration File
Information defining the characteristics of the machine which

you are designing is kept in an ASCII file entitled HPIXW.INI.
When the HPGL Controller (HPIXW.EXE) begins execution, it
reads the HPIXW.INI file from its location in the WINDOWS
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directory. The HPIXW.INI file is generated when the HPGL
Controller is run for the first time, and is accessed for set-up and
changes by means of menus and dialog boxes which are available
via the Setup menu. Since the HPIXW.INI file contains informa-
tion which is specific only to the configuration of the machine
(such as the step-to-distance ratio of the motorized stages, axis
designations, rapid traverse rates, etc.), it is not likely to need
changing after initial configuration. 

CAM Files
Information relating to the manufacturing of each part (such

as Plot File names, cutting speeds, etc.) is kept in CAM Files.
CAM Files are ASCII files with the file name extension “CAM”.
The CAM Files are opened by means of the File > Open menu,
and are accessible for editing by means of the Edit menu. 

The CAM File can be thought of as a file that keeps all of
the information relating to a particular job together. This includes
not only the tool designations, cutting speeds etc., but also the
names and locations of other files, decribed below, that relate to
making a particular part.

CAM Files contain a large amount of information, but it is
not necessary for you to manually enter all of this information
into each field for each job. CAM Files are easily replicated by
means of the File > Save As menu. One convenient approach is to
save a CAM file for each  type of job that is used often. To gener-
ate a new job, you would open the CAM file for that job type,
then using the Edit menu you would only change values associat-
ed with the job at hand. Optionally, you could save each job under
it’s own name.

On a new or upgraded installation, the HPGL Controller’s
“Setup” program installs a file entitled “SAMPLE.CAM” . You
may use this file to construct your first job. However, do not per-
menantly save job setup information in this file, as this file is
over-written each time you may run “Setup” for upgrades.
Instead, after editing SAMPLE.CAM, save your work under
another file name using the File > Save As menu.
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Plot Files 
The file which is produced by the CAD or drawing program

(such as AutoCAD or Corel Draw) for the purpose of defining the
path of the tool is called the Plot File, or HPGL File. This file
contains the commands which an HPGL compatible pen plotter
or engraver understands. These commands are  interpreted by this
program and transformed into commands which Indexer LPT
understands.

When an HPGL File is converted (post-processed) by the
HPGL Controller, Indexer LPT commands corresponding to
the geometry represented in the HPGL File are placed in a file
called a Command File.

Command Files
When a job is run, the HPGL Controller sends the Indexer

LPT commands contained in the Command File to Indexer
LPT.

As mentioned, the Command File is  an ASCII file which
basically contains Indexer LPT commands. These Indexer LPT
commands define the centerline of the actual  tool path. 

In addtion to Indexer LPT commands, the Command File
also contains lines of information that we call Directives.
Directives are special commands which are interpreted by the
HPGL Controller at “run time” when the machine is in opera-
tion under the Production > Run Tool Path menu. 

For example, there is a Directive which appears in the
Command File as #D. At run time this Directive is expanded
into Indexer LPT commands suitable for plunging the tool Down
into the work. The particular Indexer LPT commands which are
used to effect  the tool plunge are determined by system and
CAM set-up values. Likewise, there is a  #U Directive which is
expanded into a suitable retract sequence, instructing the HPGL
Controller to retract the tool Up, away from the work. Directives
are more comprehensively described in the chapter entitled TOOL
PATH EDITING.

You may never need to work directly with Directives.
However, it is important to understand that the Command File
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includes both Indexer LPT commands and Directives, and that
Directives are interpreted and expanded at run time according to
system and CAM file setup values.

The name of the Command File can be any valid file name.
However, it recommended that you use the base name of the
CAM file with “IXH” as the file name extension.

The Command File need not be generated from a Plot File.
Since the Command File is an ASCII file, you may use third
party  programs or post-processors to generate this file, even a
simple text editor such as Wordpad. (A CAM setup feature
allows you to specify an independently generated Command
File). 

The  Command File can be modified using the built in Tool
Path Editor.

Contour Specification Files
The Contour Specification File has the filename extension

“CTR”.  It is an ASCII file originally generated from the
Command File. When it is first generated, its contents may be
identical to the Command File. However, the Tool Path Editor
can add additional information into the Contour Specification
File. Specifically, information regarding tool offsets for each
shape is stored in this file. The actual amount of tool offset is
determined by set-up values contained in the Trace Width
(Cutter Diameter) field of the Pens menu (stored in the job in
the CAM file). However, information as to whether the tool will
track a contour to the left, to the right, or down the center is con-
tained in the Contour Specification File.

After using the Tool Path Editor to specify the final path, off-
sets and geometry of the tool path, and saving these changes into
the Contour Specification File, the actual path of the tool is writ-
ten back into the Command File. The essential information
regarding the geometry of the tool path is saved in the Contour
Specification File, but the script that actually controls the tool
path is contained in the Command File.

For example, suppose you use a CAD program like AutoCAD
to generate a one inch square. This square shape is “plotted” to a
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file named SQUARE.PLT. Using the Edit > Translate Plot File
menu, you generate a Command File named SQUARE.IXH. You
may use SQUARE.IXH immediately to run a job. However, if you
were using a 1/4 inch diameter cutting tool to cut a square shaped
hole in some material, the inside dimension of the square would
be 1 1/4 inches across, since a  plotter output designates the cen-
terline of the tool path. Consequently, to cut out a one inch square
you may set up the Trace Width field in the Edit > Pens menu to
1/4 inch. Then you may enter the Tool Path Editor to select the
direction of the cut as well as an offset (left or right) that will off-
set the tool towards the center of the square. From the Tool Path
Editor you select Generate Command File from the File menu.
The Command File that was just used to generate the Contour
Specification File will now be over-written with new information.
The old information will be lost, but you will not use the old
information because the most up-to-date information is now
stored in the Contour File. The new information in the
Command File specifies the centerline of the desired tool path,
which is a square with 3/4 inch legs. When run with a 1/4 inch
diameter cutting tool, this new Command File will cut a square
hole 1 inch across the sides.

Using the same example, suppose you wanted to cut the same
1 inch square hole, but you needed to use a smaller diameter tool
(say, 1/8 inch diameter) to get a smaller corner radius.  In the
Trace Width field of the Edit > Pens menu you would replace
“.250” with “.125”. Next, you would enter the Tool Path Editor
and select Generate Command File from the File menu. The
Contour Specification File will remain unchanged, but the old
Command File will now be over-written with Indexer LPT com-
mands that accommodate the new tool size.

The chapter entitled  CAM SET-UPS  describes how to call
out names for the HPGL File, the Command File and the
Contour Specification File.  This section expresses the impor-
tance of these files and their use.

Single Contour Files
This manual refers to the path of a tool when the tool is

engaged as a “contour”. This can be a point plunge, a simple
straight line path or a complex shape. The path of the tool when
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the tool is disengaged (retracted) is called a “rapid”. The Contour
Specification File contains a succession of  contours connected
by rapids. The Tool Path Editor has the capability to convenient-
ly save individual contours into a file, which can be later
retrieved, positioned and/or rotated and added into the tool path
described in the Contour Specification File.  Single Contour
Files are saved under a name that you provide with the filename
extension “.CTS”.
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Chapter 4

MOTOR CONTROL OUTPUTS

The electronic signals which are used to control the motors
are generated by the Indexer LPT device driver. The HPGL
Controller communicates appropriate commands to Indexer
LPT. Indexer LPT performs low level control over the motors
via the outputs located on the computers printer port(s). Refer to
the Indexer LPT manual for technical information regarding the
wiring and use of stepper motors, translators (amplifiers), and
limit switches.

Discrete Digital Outputs
All signal output (and input) between the HPGL Controller

and the outside world occurs through the Indexer LPT device
driver using user-selectable Indexer LPT commands. Two useful
commands for setting the voltage level on discrete output lines are
reduced_current and winding_power. The associated output sig-
nals of these commands can be used to control external devices
such as optically isolated switches and solenoid actuators.

Set-up menus allow you to specify Indexer LPT output com-
mands for different purposes. When configuring your system, it is
recommended that you first exercise whatever commands you
intend to specify using the IXDIAG.EXE program provided with
Indexer LPT, accessible from Windows using the Start >
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Programs > Indexer LPT Diag menu selection. Since IXDI-
AG.EXE allows you to control Indexer LPT directly, you can
more easily troubleshoot your design.

Limit Switch Inputs
Operational limit switches define the normal operational

boundaries of the motorized stages. Operational limit switches
may be wired to the printer port as per the instructions found in
the Indexer LPT manual.

In some systems, where stage over-travel is likely to present a
hazard, an outer set of limit switches may be used for an emer-
gency stop. The outer limit switches do not rely on software to
arrest motion. For example, in one design an outer set of limit
switches can be used to independently remove all power from the
system via a “drop out” relay. In another instance, outer limit
switches may be used in a circuit which interrupts the controlling
step pulses. The actual implementation of your over-travel safety
strategy is dependent on the machine that you are designing.

Input Query
Indexer LPT commands which are capable of determining

the status of an input signal are used by the HPGL Controller to
query the state of certain controls, such as the start switch.
Indexer LPT commands appropriate for this purpose are -limit?,
+limit?, aux?, and scan. The feedback from any of these query
commands is either a 1 or a 0, depending on the logic level or
state of the input. The HPGL Controller setup menus allow you
to assign query commands to different control functions. The
Indexer LPT manual explains the usage and syntax of these input
query commands.

All inputs to this program can be verified by means of the
Diagnostic menu. The dialog boxes contained in this portion of
the program continuously exercise the queries which you have
specified in associated set-ups, and displays a live view of the
results of these queries. You should verify all of your input query
commands using the diagnostics before using them in production
operations.
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Feed-Hold Input
In all but the smallest and simplest machines the Indexer

LPT feed hold feature must be installed.

When the motors are in motion, Indexer LPT occupies the
computers’ processor as a necessary requirement for fast and
accurate timing. Consequently, keyboard input is suspended tem-
porarily when the motors are being controlled. However, the feed
hold feature provides for immediate and controlled interruption of
tool motion. With the introduction of extensive look-ahead con-
touring, where Indexer LPT has continous control over the tool
path for longer times without interrruption, incorporation of the
feed hold feature into the machine design has become more
important - and in most cases absolutely necessary. 

The feed hold feature is conceptually simple and easy to
install as per the documentation provided in the Indexer LPT
users guide and the chapter in this manual entitled SYSTEM SET-
UPS. 

The X-Y Stages
Similar to a pen plotter, the tool path follows a pattern along

a plane which is defined by two translation stages situated on per-
pendicular axes. Movement along these axes is controlled by
means of pulse(step)/direction signals generated by Indexer LPT.

Each pulse results in an incremental movement of the associ-
ated stage. For example, assume the motor operates at a resolution
of 200 steps (pulses) per revolution, and assume the stage is
directly driven by a . 200 pitch lead screw. In this case, the step
resolution is .001 inch per step.

The HPGL Controller requires the step resolution of the X
and Y axes to be the same.

The Z Stage
The Z stage is situated along an axis which is perpendicular

to the plane which is defined by the X and Y axes. Movement
along the Z axis causes the tool to plunge into or retract from the
work.
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The Z stage can be controlled by pulse/direction signals, sim-
ilar to the X and Y stage. The HPGL Controller does not require
the step resolution of the Z stage to be equal to the step resolution
of the X and Y stages (although making the step resolution of all
stages equal may ease hardware compatibility with three dimen-
sional modeling software).

When the Z stage is motor controlled, the HPGL Controller
can adjust the plunge depth of the tool to user-selectable levels for
each HPGL pen number.

Optionally, the Z stage can be configured to be bi-positional:
extended or retracted by means of a solenoid or air cylinder. For
simple plunge operations, which only require a single depth tool
plunge, this option saves the cost of a third motorized stage.
Plunge timing can be implemented by using Indexer LPT dwell
commands, or by optional plunge and retract input switches.
Using dwell commands, the system provides a time delay to allow
the Z axis sufficient time to plunge or retract. Using plunge and
retract switches, the system uses the switch inputs to determine if
the plunge or retract operation is complete.
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Chapter 5

MENU USAGE

General
The HPGL Controller is set up and controlled by means of

menus and dialog boxes. Options are selected similarly to many
Windows programs using the mouse or keyboard. 

If a mouse is not available, press and release the Alt shift to
move the highlight to the Main Menu bar. Use the cursor keys to
navigate the menu or press the character key corresponding to the
underlined letter of the menu item to select. Use the cursor keys
or character keys in a similar manner to select the menu item
from the drop down list. Drop down menu selections which con-
tain an elipsis (three dots ...) invoke another menu or a dialog box.
You may navigate the dialog boxes using the Tab key to change
the highlight, and the Space key to select an item, change a check
box, or press a button. Use the cursor keys to change Radio
Button selections (these buttons look like little radio dials), or to
scroll through selections of a list box. Press the Enter key to
accept changes, or Escape to abandon changes.

Making selections using a mouse is much easier. Simply
locate the cursor over the desired item and snap the left button on
the mouse. (The mechanisms in a conventional mouse may not be
suitable for a shop environment. You may consider using a Touch-
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Pad as an alternative). When making changes in a Dialog Box,
select Ok to accept changes, or Cancel to abandon changes.

Two Types of Setups
From the Main Menu you may obtain access to the Setup,

Production and Diagnostic menus. Set-up features are broken
down into two categories: system Setup, and CAM Edit.

The first category of set-ups involves parameters relating to
the design of the machine ,and are not likely to be changed in
normal production operations. These set-up values are stored in a
file named HPIXW.INI (located in the WINDOWS directory ) and
are accessed by means of the Setup menu. This menu can be
password protected. The initial password to access this menu is
“abc”. Once you have access to this menu, you may change the
password. The password helps prevent inadvertent access to sys-
tem setups and is NOT an iron-clad access lock. If you forget
your password, you can find it by printing the HPIXW.INI file.
The password will appear to the right of the keywords:

system password=

The other category of set-ups involves parameters relating to
a particular machine operation, such as the name and location of
the tool path files (Plot Files), cutting speeds, scaling etc. These
set-ups are stored in files with “CAM” as the filename extension.
We refer to them as CAM Files.

CAM Files are loaded using the File > Open CAM File
menu. CAM Files are changed using the Edit menu. You may use
the changes you have made to the CAM set-up without saving the
changes to disk. Alternatively, you may save the changes using
the File > Save menu, or save changes to a CAM File of another
filename using File > Save As.

You may optionally restrict access to the CAM set-up by
means of a password. Similar to the system password, the pass-
word protection for the CAM set-up is only meant to prevent
inadvertant changes, and not as an iron clad access lock. The ini-
tial password to access CAM set-up is “def”. If you forget your
password, you can find it by printing the HPIXW.INI file. The
password will appear to the right of the keywords :
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camedit password=

Tool Motion
All tool motion is controlled from within the Production

menu. All selections under this menu bring up a dialog box pre-
senting to the user the oportunity to proceed or cancel the opera-
tion. If the user selects Ok to proceed, a prompt appears requiring
the user to press Start (or Ctl-F2 if the software is set up for
Keyboard Start). At this point the user can still abort the opera-
tion by selecting Cancel. Once the Start signal is received,
motion commences. The software can be set up to accomodate
three different Start options: Keyboard Start, Start Switch, or
Dual Start Switch. 
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Chapter 6

SYSTEM SET-UPS

System set-up values may be accessed by means of the Setup
selection of the Main Menu. Values are stored in the HPIXW.INI
file, which is located in the WINDOWS directory.
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X-Y Stage Configuration

Feed Motor X Axis
Feed Motor Y Axis

These fields contain the Indexer LPT axis designation for
the X and Y stages. Acceptable values are “a” through “f”.

XY Units Name

Select the name of the dimensional units for X and Y motion
from the list e.g. in for inches, cm for centimeters etc. This selec-
tion ONLY affects the units annotations, which appear in various
places in this program, and DOES NOT automatically set up the
appropriate ratio of step motor steps to units which is explained
below.

Ratiometric Steps per Unit(s)
Ratiometric Units
The ratio of the Ratiometric Steps per Unit(s) to Ratiometric
Units defines the motion of the stages in proportion to the step
pulses generated by Indexer LPT. Use a convenient number for
Ratiometric Steps per Units(s) and a corresponding number for
Ratiometric Units.

Your machine must be constructed to use the same steps to
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distance ratio for both the X and the Y axes.

For instance, assume you are directly driving a .200 inch lead
screw with a step motor configured for 400 steps per revolution.
In this case, 400 steps would move the stage by .200 inches. You
may enter a value of 400 in the Ratiometric Steps per Unit(s)
field and a value of .200 in the Ratiometric Units field. Select
“in” from the XY Units Name list box to make the other menus
and dialogs read correctly.

Assume this same machine is to be used in CAD/CAM oper-
ations where centimeters is the standard of measure. In this case,
since .200in = .508cm, enter a value of .508 in the Ratiometric
Units field. In this case  “cm” is the most appropriate selection
for XY Units Name.

In another example, assume that you are driving the X and Y
stage by means of a cable system. You have determined experi-
mentally, using the Indexer LPT Diagnostic Program and an
appropriate measuring device, that commanding the motor to
move 3000 steps results in a movement of 3.103 inches. In this
case, enter a value of 3000 in the Ratiometric Steps per Unit(s)
field, enter a value of 3.103 in the Ratiometric Units field, and
select “in” for XY Units Name.

Total Distance Along X Axis
Total Distance Along Y Axis 

These fields represent the distance of travel along the associ-
ated axis. Typically this is the distance between the high and low
operational limit switches. In a Limit Switch Seek operation
(available from the Production menu), if the stage does not con-
tact the limit switch after traveling the distance specified here,
motion will cease and a warning message will appear.

Z Stage Configuration

Z Axis is Motor Controlled?

This box is checked if you are using a step motor controlled
stage for tool plunge. If it is not checked, the tool plunge may be
controlled by a discrete digital output command. The status of this
check box changes the dialog box to present an appropriate set of
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set-up options.

Note: A step motor controlled Z stage will allow you to spec-
ify the plunge depth for each pen number (Edit -> Pen
Definitions Plunge  Depth). It will also allow you to plunge
incrementally deeper with each tool path pass (Edit -> Tool Path
Plunge Offset) for special operations such as pocket milling.

Feed Motor Z Axis

This field contains the Indexer LPT axis designation for the
Z axis. Acceptable values are “a” through “f”. This field may not
specify an axis which is being used for the X or Y stages.

Z Units Name
Ratiometric Steps per Unit(s)
Ratiometric Units
Total Distance Along Z Axis
Display Position to Total Distance Along Z Axis

These categories are similar in function to their counterparts
in the XY Stage Configuration.

Z Stage Solenoid Configuration
These fields in the Z Stage Configuration dialog box appear

only if the check box Z Axis is Motor Controlled is not checked.

Indexer LPT Command to Plunge

This field contains an Indexer LPT command which will be
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executed upon each tool plunge (pen down). This command typi-
cally controls a discrete digital output used to control a solenoid
actuator.

Indexer LPT Command to Retract

This field contains an Indexer LPT command which will be
executed upon each tool retract (pen up). This command typically
controls a discrete digital output and reverses the operation of the
command to plunge.

Wait for Input Events on Plunge and Retract

It is usually necessary to make provision for the time it takes
for the tool to plunge (and retract) before proceeding with the fol-
lowing X-Y motion command. One method which can be used is
to introduce a time delay using the CAM set-up menu. Another
method is to wait for an event, such as a switch closure, before
proceeding. A check in this check box chooses the latter method.
The following Plunge Query fields only appear in this dialog box
if this check box is checked.

Indexer LPT Command to Query Plunge Switch
Plunge Query Result
Indexer LPT Command to Query Retract Switch
Retract Query Result 

Indexer LPT commands are used to determine the status of
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the plunge and retract switch signals. Indexer LPT commands
which are appropriate for this purpose are -limit?, +limit?, aux?,
and scan. The value of the Query Result field should be the
Indexer LPT response, “1” or “0”, when the switch is actuated at
the completion of the cycle. These fields are only visible when the
the Z Axis is Motor Controlled check box is not checked and the
Wait for Input Events on Plunge and Retract check box is
checked.

Limit Switch Seek Configuration

Options for the Z axis will only appear if Z Axis is Motor
Controlled option is checked in the Setup > Z Stage
Configuration dialog. (Maximum value numbers and dimension-
al annotations (in, cm) that appear in the sample dialog in this
manual do not pertain to your system). 

Seek Low Limit Switch

This dialog box allows you to choose whether the
Production > Limit Switch Seek operation will seek the high or
low limit switch of the associated axis.

(If the Z Axis options are visible) note that since the direction
of travel to retract the tool is positive (plunge is negative), it is
usually convenient to configure the Z axis to seek the high limit
switch, as this cycles the stage towards the most retracted loca-
tion.

Set Home After Retract
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A check in this check box causes the program to automatical-
ly set the position counter of the associated axis to zero (home
position) after the Production > Limit Switch Seek sequence.

Retract Distance

These fields specify the distance the stage will retract from its
associated limit switch when using the Production > Limit
Switch Seek operation.

Rapid Traverse Rates

Starting Speed
Running Speed
Acceleration 

Options for the Z axis will only appear if Z Axis is Motor
Controlled option is checked in the Setup > Z Stage
Configuration dialog. (Maximum value numbers and dimension-
al annotations (in, cm) that appear in the sample dialog in this
manual do not pertain to your system). 

Generally speaking “rapid traverse” relates to stage motion
when the tool is not in contact with the material. For the X-Y
axes, rapid traverse rates apply when the tool is retracted. For the
Z axis, the rapid traverse rates apply to the rates used in plunging
to the offset position and in retracting the tool.

Speeds are represented in units per minute. The names of the
units which are represented (in, cm etc.) are the names which
were set up in the Setup > Stage Configuration > Units Name
fields. Acceleration is represented in units per minute per second.
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The Starting Speed field represents the instantaneous rate at
which the stepper motor will begin motion. The motors then
accelerate to the plateau velocity defined by contents of the
Running Speed field. The Starting Speed must never be set to
exceed the Running Speed. The values which you set up in this
dialog box will largely depend on the limitations of your system.

One limitation is the maximum step rate of which your com-
puter is capable. The dialog box displays maximum values of
speed and acceleration which can be attained by your computer.
(Note that these values are calculated on the basis of computer
speed in combination with other setups).

Another limitation depends on the power of your step motor
drive system. You should not set the starting speed faster than
your motors can instantaneously start. Neither should you set the
acceleration faster than the capabilities of the motor drive system.
Safety and the physical strength of your system components are
also considerations.

Controls Configuration

Feed-Hold Feature is Installed

This feature must be installed in all but the smallest and sim-
plest applications.
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This check box should be checked if the system is designed
to utilize the Indexer LPT feed hold feature. Refer to the
Indexer LPT documentation for a detailed explanation of the
feed hold feature.

Feed-Hold Axis

This item only appears if the Feedhold Axis is Installed?
check box is checked. This field contains the axis designator for
the feed hold feature. Allowable values are “a” through “f”. You
cannot designate the same axis for both joystick and feed hold.
You cannot specify here any axis which is being used for motion
control on the X, Y or Z stages.

Joystick-Jog Feature is Installed

This check box should be checked if the system is designed
to utilize the Indexer LPT joystick feature. When this box is
checked, fields which relate to setting up the joystick controls
appear in the dialog box.

Joystick-Jog Axis

This field contains the axis designator for the joystick jog fea-
ture. Allowable values are “a” through “f”. You cannot designate
the same axis for both joystick and feedhold. You cannot specify
here any axis which is being used for motion control on the X, Y
or Z stages.

For a more thorough explanation on the implementation and
wiring of the joystick and feedhold features, consult the Indexer
LPT documentation.

Indexer LPT Command to Query Release Switch
Release Switch Query Result

The release switch input is used by the HPGL Controller to
determine when the operator wishes to exit the joystick jog mode.
The release switch input can be set up for any Indexer LPT
query which responds with “1” and “0”.

The machine designer may consider using the feedhold abort
input for this purpose. Since feedhold abort releases the machine
from a suspended motion state, and since the feedhold feature is
never active in joystick jog mode, a single input entitled “release”
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may be used to accomplish a dual purpose.

Keyboard <Ctl><F2> Start Switch

When this check box is checked motion sequences requiring
a Start sequence are initiated by simultaneously pressing the key-
board Ctrl and function key F2 . If this box is not checked, exter-
nal signals are used for Start, and appropriate set-up fields appear
in the dialog box.

Indexer LPT Command to Query Start Switch
Start Switch Query Result

The Start input is used by the HPGL Controller to deter-
mine when the operator wishes to initiate motor movement. The
Query Start Switch field can be set up for any Indexer LPT
query which responds with “1” and “0”. Start Switch Query
Result represents the query result necessary for motion to com-
mence.

CAUTION
Using the Auxiliary Input signal for the start switch may pres-
ent a safety hazard. Unless terminated to either ground or logic
1 (5 Volts), the Auxiliary Input signal may randomly fluctuate
and could possibly cause a spurious Start, a dangerous condi-
tion. Even if properly terminated, note that an accidentally
unplugged cable could break external termination and present
this hazard. If you use the Auxiliary Input for a Start signal, you
must design appropriate safeguards into your wiring.
Otherwise, avoid using the Auxiliary Input for this purpose.

Require Two Start Switches
Indexer LPT Command to Query Second Start
Switch
Second Start Switch Query Result

In some applications it is prudent for safety to require the
operator to occupy both of his hands before motion is allowed to
commence. This option provides for a second switch input for
Start. 

Jog Settings
This dialog is available only if the Setup >  > Controls >
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Joystick-Jog Feature is Installed check box is checked.

Jog Instantaneous Speed

This field sets up the speed for joystick control when the
instantaneous rate switch de-selects accelerated motion.
(“Instantaneous” rate means constant speed). Refer to the Indexer
LPT documentation relating to joystick hard-wired options.

Jog Nudge Distance

One of the joystick hard-wired options allows allows the
operator to switch select a “nudge” mode, which sends a pre-
selected burst of steps every half second whenever the operator
activates a joystick switch. The resulting motion appears to
“nudge” the stage in small increments, allowing for very fine
positioning. This field sets up the distance corresponding to the
burst of steps.

The after pressing OK, the value is rounded off to the resolu-
tion of the nearest step increment. To view the actual value being
used simply bring in the dialog again. Very small values will be
presented in scientific notation. The decimal precision of the dis-
played values will correspond to the set-up entry in the Setup >
Stage Configuration > Display Position to Decimal Places
field.

Multiple Head Configuration

Head No.

When the Setup Number of Heads setup-up calls for more
than one head, this dialog box is available from the Setup menu.
Heads are associated with HPGL pen numbers in the Edit Pen
Definitions dialog. This feature may accommodate a variety of
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physical configurations depending on the design of the machine.
The Head No list box allows you to select a set-up menu pertain-
ing to each Head.

Head Offsets

These values designate a distance from an arbitrary location
on an X-Y gantry. For simplicity, this position is often selected as
the position of Head No 1 (offsets for Head No 1 would be zero).
In this case, the Head Offsets of subsequent heads comprise the
distances that the particular head resides from Head 1 in the X
and Y directions. In actual operation, when the Head is changed
by means of a menu selection, or as a result of a pen change, the
X-Y Stages automatically adjust in position according to the set-
up values in these fields.

Head Change Commands

This section contains an arbitrarily long list of Indexer LPT
commands which are performed during a Head change operation.
When a different Head is selected, first the X-Y carriage is
adjusted according to the Head Offsets, then this list of com-
mands is sent to Indexer LPT.

The list editor allows you to easily add, insert, and delete
commands to the list. To add a command to the end of the list,
simply type the command into the Edit field and snap on the Add
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button. To insert the command into the list, snap on the location in
the list where you want the command to be inserted, then snap on
the Insert button. Likewise, to delete any item from the list, high-
light the list item with the cursor, and snap on the Delete button.

Password

System Setup
CAM Edit
Change Passwords

Password access is provided to protect System and CAM set-
ups from accidental modification. These passwords should be
used only to avoid accidental modification of setup values and
not as an iron-clad protection against access to certain fea-
tures. The initial password which comes with the product is “abc”
for the System Setup and “def” for CAM Edit. You may choose
not to use this feature, or temporarily restrict access without
changing the set-up.

If you forget your password, you can find it by printing the
HPIXW.INI file. The password will appear on the line under the
section:

[Password]

Save Setup File
This selection will save the current system configuration to

the HPIXW.INI file, located in the WINDOWS directory.
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Chapter 7

CAM SET-UPS

CAM set-ups can be modified by means of the Edit menu.
These set-ups are stored in ASCII files with “CAM” as the file-
name extension. We refer to them as CAM Files (Chapter 3).

A CAM File is selected by means of the File > Open menu
selection. Note that the initial directory which the file browser
displays is the “Start in:” field which is set up under the
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Windows Shortcut. (To change the working directory, right snap
over the HPGL Controller’s icon and snap over the Properties
selection of the pop-up menu that appears. Snap over the
Shortcut tab, then enter the complete path to the location of your
CAM File’s in the field entitled “Start in:”).

The CAM Files contain information which pertains to the
individual part which is being manufactured. CAM Files contain
a substantial amount of information, some of which will change
from job to job and some of which will not. To save you the trou-
ble of having to enter information that will not change, the HPGL
Controller makes it easy to duplicate CAM Files, so that you
may edit only the items that need to be changed. It may be con-
venient, therefore, to have a number of template, or “default”
CAM files that contain information pertenent to different types of
jobs that you may run. Refer to the section of this manual entitled
Making “default” CAM Files, located in the chapter entitled
CAM FILE SET-UPS.

Tool Path

Independent Command File

Check this box if you wish to decouple the Command File
from the HPGL File. This feature can also be used when you are
generating the Command File by means of another program,
making the HPGL File Specification irrelevant.
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HPGL File

This field contains the file specification (drive:path\filename)
of the HPGL File which is being used to generate the tool path.
The Edit > Convert CAM File menu selection converts the
HPGL instructions into Indexer LPT commands, and places
them in a Command File.

Contour Specification File

This file is originally generated from information in the
Command File. The purpose of the Contour Specification File
is to store additional information regarding the tool path, such as
the tool path offset, contour order and direction.

The Tool Path Editor can be used to order the tool path and
specify the offsets. The Tool Path Editor is entered by snapping
over the Edit button located to the right of the Contour
Specification File field in this dialog.

If the Contour Specification File field contains no entry, or
if it contains the entry “none”, when the Edit button is snapped a
file name will be created using the name of the CAM file as the
base, and “.ctr” as the file name extension.

Command File

This field contains the file specification of  the Command
File. The Command File controls the actual path of the tool
when a job is run. Any valid file name can be used. It is recom-
mended, however, that you use the same file name root as the
CAM file with “.ixh” as the extension. For example
MYJOB.CAM would have a Command File Specification of
MYJOB.IXH.

Use Caution when Naming Command Files

It is possible to specify the same Command File in more
than one CAM File. This can be very useful. Suppose you are
manufacturing a particular part from different materials. The
Command File will be the same, but the tool speeds may vary
according to the material being used. In this case you simply set
up the different pen speeds under different CAM Files , but keep
the Command File Specification the same in each CAM File.
You are at liberty to change other CAM set-ups as well: plunge
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depth, tool passes, offsets, etc. without needing a separate
Command File for each CAM file.

This flexibility introduces a possibility for error, since
changes which affect the generation of the Command File, such
as changes to the HPGL File, changes to Scaling, or other
changes introduced under the Tool Path Editor will affect all
CAM files which specify the same Command File name.
Consequently, in most applications it is desirable to give the
Command File a unique name. It is recommended that the name
of the Command File reflect the base name of the CAM File,
only with “IXH” as the extension. You are given an option to have
this done for you automatically when you save a CAM File using
File > Save As.

Plunge Offset per Pass

This field only appears when the Z axis is stepper motor con-
trolled. In some applications it is desirable to repeat a tool path,
while incrementally lowering the Z stage to increase the depth of
cut. This field represents the distance the plunge depth will be off-
set after each pass. If incremental increase in plunge depth is not
desired, zero depth should be specified. Plunge depth is always a
negative value.

Passes

The value in this field determines the number of times the
Command File will be traversed.

Scaling

Scale Factor

This field governs the proportional size of the tool path when
converting the HPGL File to the Indexer LPT commands in the
Command File. For example, if you desire the tool path to be
equivalent to the size specified in the HPGL File (1:1 scale),
make the value of this field 1. If you wish the tool path to be
three-quarter size, make the value .75, double-size 2, etc. This
field ONLY affects the Edit > Convert HPGL File process and
has no effect on independent or pre-existing Command Files.
(When you change the Scale Factor you must execute Edit >
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Convert HPGL File for the change to take effect.) 

Ratiometric Plotting Units
Ratiometric Motion Units

The ratio of these fields determines the proportional size of
the tool path. Unlike the “Scale Factor” field, however, once you
determine the values for these fields, you will have little need to
change them.

The values that you enter into these fields are determined by
the plotter characteristics with which your CAD program is set to
work. For example, if your CAD program plotter driver is config-
ured for use with the HP 7475 plotter, the numerical values which
define motion in inches will reflect a ratio of 1020.9:1. The num-
ber “1020.9” is in dimensions of “plotting units.” In this case the
number “1” is in units of inches. Your CAD program, therefore,
designates a distance of 1/1020.9 or (.0009795) inches per plot-
ting unit. Be careful to use the same dimensional motion units in
this field (e.g., inches, millimeters, etc.) as you use for the X-Y
stage in system set-up: Setup > XY Stage Configuration.

Plotting units are generally integer values. Consequently, the
plot unit resolution of a 1:1 plot for an HP 7475 plotter is
.0009795 inches. One way to increase the plot resolution with the
HPGL Controller is to increase the scale factor in your CAD
program when generating the plot file. You may then compensate
for the increased size by decreasing the scale factor in the Scale
Factor field of this dialog box. Plot unit resolution will vary in
proportion to scale factor. In the previous example a double-size
plot and an accompanying .5 scale factor will result in a plot unit
resolution of (.5)x(.000975) = .0004897 inches.

As with the Scale Factor field, if you make changes to these
fields you must execute Edit > Convert HPGL File for the
changes to have effect.

Arc Translation
In order to more completely control the tool path look-ahead,

feed hold, and re-trace, the HPGL Controller breaks up circular
motion into individual straight line segments. The manner in
which these segments are generated is controlled by this menu.
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Ultimately, the Command File that is used to control tool
path motion must only contain Indexer LPT feed commands for
contouring and move commands for rapid traverse. The HPGL
Controller converts circular motion commands to feed commands
in two different manners.

HPGL Conversion

Most CAD programs convert circles and arcs to HPGL line
segments before generating the Plot File. In these cases, the CAD
program itself may have a similar menu to this, giving the user
control over the resolution and accuracy of the approximation
process. When circles and arcs are broken up into line segments
within the CAD program before generating the HPGL Plot File,
set-ups in this menu have no effect.

However, if the CAD program generates HPGL circular inter-
polation commands, this menu governs how they are to be inter-
preted. The specific HPGL commands are AA (Arc Absolute),
AR (Arc Relative) and CI (Circle). (If you have a text editor that
enables you to view the data in your Plot File, you may be able to
determine if your CAD program is generating these commands by
looking for them. You can also TYPE a Plot File to the screen
from a DOS prompt using the /p option to avoid rapid scrolling,
and try to visually detect the presence of these commands).

Independent Command File

If Indexer LPT arc_to and circle commands occur in a
Command File (that, for example may have been generated out-
side of the HPGL Controller, or generated by earlier versions of
the HPGL Controller) then that Command File is not suitable
for production operations. However, you can use this file to gener-
ate a suitable Command File by bringing it into the Tool Path
Editor using the Tool Path > Edit button. From the Tool Path
Editor you must over-write the old Command File with a newer,
segmented type using the Tool Path Editor’s File > Generate
Command File menu.

Guidelines

Do NOT enter tolerance requirements that greatly exceed
your manufacturing requirement. A greater number of segments
will result in larger file sizes and longer pre-calculation dwell at
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run time. Excessive values may even compromise the quality of
the machine motion.

Segment Angle

This is the maximum angle that the arc will be approximated
across. In other words, as long as the geometry does not violate
the Segment Error, or the Maximum Segments per Arc, the arc
will be constructed in segments subtending Segment Angle or
less.

It is important to note that Segment Angle is a maximum
angle, and that the total included angle of the arc is not limited to
resolve to this angle. In other words, if the Segment Angle was
specified as 5 degrees, an 8 degree arc will be drawn using two
segments subtended by 4 degrees. A ten degree arc will be drawn
using two segments subtended by five degrees.

This setup is useful in optimizing jobs where tolerances of
smaller radii arcs are held tighter than the Segment Error
allowed in larger radii arcs.

Segment Error

This value is the maximum dimensional error due to linear
approximation. In other words, it is the farthest distance that the
segment deviates from the true theoretical arc.

This set-up over-rides Segment Angle. Smaller arcs subtend-
ed at Segment Angle may generate errors which are less than this
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set-up value. Larger arcs are broken down into more segments so
that Segment Error is not violated.

Maximum Segments per Arc

This value over-rides both Segment Error and Segment
Angle. The number of segments used to approximate an arc is
limited by this value.

Translate Plot File
Select this menu item when you wish to generate a

Command File from the Plot File specified in the Tool Path dia-
log. 

If the Plot File > Independent Command File check box is
checked, then this menu item has no meaning and is therefore dis-
abled. The Command File in this case is not associated with a
Plot File.

If you are not set up to use an independent Command File,
then you may use this menu function to generate one, since it is
the Command File which is actually used to direct the tool path.

If you have already generated a Command File, and you
make changes to the Plot File, or if any change are made in the
Scaling dialog, then you must repeat this menu function to incor-
porate the changes. You do not have to repeat this menu function
if changes are made to the Plot File > Plunge Offset per Pass, or
the Plot File > Passes set-ups. 

You do not have to repeat this function if CAM set-up
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changes are made to dialogs accessed from below the separator
bar in the Edit menu: Auxiliary Tool Path Commands, Pen
Definitions, Pause for Tool Change, Auxiliary Plunge/Retract
Commands, Initial Offsets, Contour Tool Feed, and Step and
Repeat.

Auxiliary Tool Path Commands

Indexer LPT Commands Before Tool Path
Indexer LPT Commands After Tool Path

These list editors specify Indexer LPT commands which
will be executed before and after each tool path traversal.

Pen Definitions
When this selection is made, a menu appears which allows

you to edit parameters which are associated with each HPGL pen.
In an ordinary plotter, the pen number usually designates a color
or line width. The HPGL Controller uses the pen number to des-
ignate additional machine control features.

Pen Number

This list box selects the HPGL pen number. When the menu
is first invoked, Pen 1 is selected, along with set-up parameters
which are associated with Pen 1. When Pen 1 is selected the
Copy button is active, which allows you to automatically copy the
values of Pen 1 to all the other pens. If any of the values have
been changed, the program allows you to cancel the change. Once
the pen change is accomplished, the values for the previous pen
are saved into the program as if you snapped the Ok button dur-
ing the editing session.

Head

If Setup > Number of Heads specifies more than one Head,
then a unique Head number may be associated with each pen
number. During the Production > Run operation the program
will execute a Head change operation when the pens are changed
if the the head number of the new pen changes from the previous
pen. A head change operation consists of moving the X-Y car-
riage to the relative offset specified in the Setup > Multiple Head
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Configuration dialog, and executing the command list specified
in the Setup > Multiple Head Configuration dialog.

Feed Starting Speed
Feed Cutting Speed
Feed Acceleration

These fields determine the motion dynamics of the X-Y axes
during the pen down phase of the tool path traversal. The Feed
Cutting Speed is the vector rate, or the speed of the tool along its
path. The dominant axis (“dominant” refers to the axis which is
being moved the greatest extent) starts motion instantaneously at
the Feed Starting Speed, then accelerates at the Feed
Acceleration rate until it reaches the speed required to maintain
the Feed Cutting Speed.
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Max Contouring Feed Shift

The value in this field only has significance if the Contour
Tool Feed feature is enabled. Contouring Feed Shift is a value
which represents the maximum instantaneous shift in velocity
which is allowed when passing from feed command to feed com-
mand in contouring operations. (For a more thorough explanation
of the implications of Feed Shift, refer to the Indexer LPT man-
ual.) Generally speaking, increasing the value of Feed Shift will
cause a more uniform cutting velocity across complex tool paths.
Increasing Feed Shift will also increase the stress on the X-Y
motor drive system.

The value of Feed Shift cannot exceed the value of Feed
Starting Speed.                                                                    

Plunge Depth

This field only appears when the Z axis is configured for step
motor control. The value in this field determines the distance the
Z axis will plunge during a pen down operation. It should be
noted that the total distance which the Z axis will plunge is the
sum of the accumulated plunge offset per pass (if any) in addition
to this value. Plunge Depth is always a negative value.

Plunge Starting Speed
Plunge Cutting Speed
Plunge Acceleration

These fields only appear when the Z axis is configured for
step motor control. These fields determine the motion dynamics
of the Z axis during lower portion of the plunge cycle. (The
motion dynamics of the Z axis during the upper plunge offset por-
tion of the plunge cycle, and the retract cycle, are set up in the
Setup > Rapid Traverse Rates dialog.)

Trace Width (Cutter Diameter)

This field determines the offset distance from the contour
path that the Tool Path Editor will use when it over-writes the
Command File. 

The Contour File specifies whether there is no offset, or
whether there is left offset, or whether there is right offset for
each contour. The Contour File also specifies which pen number
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is used for each contour. This field determines the amount of off-
set to be used.

For example, consider a contour using Pen 1 and having the
offset properties of “Right Offset”. If this field contains the value
of  0.250 inches, then the amount of offset would be one half of
this amount, or 0.125 inches.

It is important to note that this field is ONLY used by the
Tool Path Editor when the Command File is being over-written
by means of the Tool Path Editor’s File > Generate Command
File menu selection. Changes to this field do NOT take effect
apart from this action within the Tool Path Editor.

For example, suppose you wish to cut out  one inch square
shapes using a .250 diameter cutter. You may draw a one inch
square shape using your CAD program, generate an HPGL File,
then generate an initial Command File using the Edit >
Translate Plot File selection from the Main Menu. Now, select
the Pen Definitions menu for Pen 1, and enter 0.250 into the
Trace Width (Cutter Diameter) field. Next enter the Tool Path
Editor by snapping over the Edit button in the Edit > Tool Path
dialog.  Select (highlight) the contour using the mouse or the Tab
key on the keyboard. Using the dialog that appears  when you
snap over the Edit > Offset Properties menu selection of the
Tool Path Editor, make sure that Pen 1 is assigned to the con-
tour, and select an appropriate offset. The offset path associated
with Pen 1, which is a distance of 0.125 inches from the contour,
will appear on the screen when you select the offset. To make the
offset take effect, from the Tool Path Editor select File >
Generate Command File. The original Command File, which
was generated by means of the Edit > Translate Plot File action,
will be over-written with new geometry that accounts for the off-
set tool path.

In this example, suppose that you wish to run the job at a
later time, but you wish to use a .375 diameter tool instead of a
the .250 diameter. Enter the Pen Definition dialog for Pen 1 and
change the value of the Trace Width (Cutter Diameter) field
from 0.250 to 0.375. Please note that changes will NOT be imme-
diately effected. You must then enter the Tool Path Editor. (At
this time, you can visually inspect the change in offset value). To
make the change take effect, from the Tool Path Editor select
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Generate Command File from the File menu to over-write the
old Command File. Once the Command File is over-written, the
changes in Trace Width (Cutter Diameter) will become effec-
tive. 

Pause for Tool (Pen) Change
If the entry in the dialog box field is “Yes,” the system will

pause the Production  > Run operation when the HPGL pen
number is changed. This option is useful when a tool or set-up
must be manually changed for each pen number.

Auxiliary Plunge/Retract Commands

Indexer LPT Commands Before Plunge
Indexer LPT Command After Plunge
Indexer LPT Command Before Retract
Indexer LPT Commands After Retract

These fields designate Indexer LPT commands which are
executed in conjunction with each plunge and retract process. The
sequencing of the commands occurs as the respective field names
imply.

Initial Offsets

X Axis
Y Axis
Z Axis

At the start of the Production > Run Tool Path operation the
stages will be positioned to an initial offset specified by these
fields. Note that the Z axis field will only appear in this dialog

box if the Z axis is set up for stepper motor control.

Contour Tool Feed
If “Yes” is selected, the HPGL Controller will take advan-

tage of the Indexer LPT contouring feature. The contouring fea-
ture queues the feed commands, then executes the queue as a sin-
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gle command, smoothly controlling the velocity from feed com-
mand to feed command. If “No” is selected each feed command is
sent to Indexer LPT individually.

Step and Repeat
This feature uses the Command File to manufacture a matrix

of parts arranged along rows and columns. The tool path is com-
pleted on each part before progressing to the next. Row and col-
umn positions are incrementally indexed starting with the part in
the first row in the first column.. This part is located in the corner
of the matrix which faces the negative direction of the X and Y
axes. Consequently, the row and column positions increase as the
row and index increases. 

Part to part progression occurs up and down along the rows.
Row to row transition occurs up the end most columns. This “zig-
zag progression from part to part is repeated until the upper-most
row is complete.

Number of Parts in Row
Number of Parts in Column

The names of these fields denote there purpose. Note that
Number of Parts in Row designates the number of columns, and
Number of Parts in Column designates the number of rows in
the matrix. The number of parts in the matrix is the product of
these two fields. If both or these fields designate “1”, then only
one part is being made (a 1x1 matrix), and the Step and Repeat
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feature is essentially disabled.

Index Distance Along X Axis
Index Distance Along Y Axis

These fields designate the distance between the parts in the
matrix. The Index Distance Along X Axis designates the part to
part distance along the X Axis, or the distance between columns.
The Index Distance Along Y Axis designates the part to part dis-
tance along the Y axis, or the distance between rows. Note that
the specified distance is between corresponding points on each
part and NOT the separation distance between the closest adjacent
points on each part.

Start Row Index
Start Column Index
Finish Row Index
Finish Column Index

Parts in the matrix can be located by their Row and Column
Index. The Row Index value designates the part position along
the row. Row Index can be thought of as “Column Number”.
Likewise, Column Index value designates the part position along
the column. Column Index can be though of as “Row Number”.

In production operations it may be necessary to start and stop
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at intermediate positions in the matrix. Use these fields to desig-
nate which part position to start and which to stop. As you change
these fields the dialog will display the number of repeat patterns
adjacent to Total Number of Parts.

In the example below, a Step and Repeat pattern is set-up
with three parts to each row (three columns), and four parts to
each column (four rows). Production will begin with the part des-
ignated by Row Index 2 (Column 2), and Column Index 1
(Row 1). Parts will be completed along Row 1 from left to right
until the end of the row is reached, at which time the part in the
next row immediately above (Row 2) will be started. From there,
parts will be completed from right to left until the beginning of
the row is reached. Row 3 will then be completed from left to
right. Row 4 will be completed from right to left until the part
designated by the Finish Row Index and Finish Column Index
is reached. In the example, this part is in Column Index 4 (Row
4), and Row Index 3 (Column 3).

The easiest way to visualize the Step and Repeat process is
by means of the View  > Toolpath Preview menu function. Using
this function the part paths are drawn on the screen in the order in
which they would occur in production operations, making it easy
to experiment with different set-up values and to observe the
order of operations. (Note that in the illustration the limit switch
boundaries are shown with a dashed line. You must first execute
Production > Set Home on the X and Y axes in order to see the
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limit boundaries using View > Toolpath).
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Chapter 8

TOOL PATH EDITING

Generating Command Files
As mentioned in the chapter entitled IMPORTANT FILES,

the Command File contains the information that the HPGL
Controller uses when the job is run. This information includes
Indexer LPT commands that are sent to Indexer LPT without
modification, such as move and feed commands, as well as
Directives, which are expanded at run time into appropriate
Indexer LPT commands or sequences of commands. The specific
commands that the Directives may be expanded into is deter-
mined by job and system setups at run time. Indexer LPT move
commands are used for rapid traversal when the tool is retracted.
Indexer LPT feed commands are used to traverse a contour when
the tool is engaged after a plunge cycle.

(It may be helpful to review the chapter entitled IMPOR-
TANT FILES at this time).

One way to generate a Command File is to use the built in
HPGL conversion utility, which is accessible from the Main
Menu’s Edit > Translate Plot File menu.

Another way to generate a Command File is with an ordi-
nary text editor, such as Notepad or Wordpad. You must be careful
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always to save the Command File as ASCII text. (You can use an
ordinary text editor to view the text of a Command File that was
generated by another method).

Still another way to generate a Command File is by means
of the built in Tool Path Editor. The Tool Path Editor initially
reads the information contained in a Command File, then it
allows you to graphically add certain information and make modi-
fications. The modified and new information is stored in another
file, called the Contour Specification File. Finally, using the
additional information contained in the Contour Specification
File, the Tool Path Editor lets you generate a new Command
File, over-writing the old.

Command File Directives
These directives are ASCII characters that appear in the

Command File as lines of text.

#D

Pen Down - This directive causes a tool plunge sequence.

#P

Pen Park - This directive causes the carriage to return to zero
position. Note that this directive DOES NOT include a number
following the “P”, as in the Select Pen directive “P1”, “P2” etc.

#Pn

Select Pen - The “n” in this directive designates a pen num-
ber, such as “#P1”, #P2 etc. This directive causes the pen to
change from its present pen assignment to the assignment speci-
fied by “n”.

#U

Pen Up - This directive causes a tool retract sequence.

Command File Rules
Command Files contain a sequence of commands in the

order that they shall be executed at run time. Indexer LPT move
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commands are used for rapid traversal when the pen is retracted at
the beginning of the job or after the #U directive. Indexer LPT
feed commands are used when the pen is plunged (engaged) after
the #D directive. The default pen number when a job is started is
Pen 1. Pen numbers remain in effect until changed by the #Pn
directive. Each directive and Indexer LPT command is delimited
by a carriage return and line feed, making each directive and each
Indexer LPT command appear on separate lines when viewed
with an ASCII text editor. No additional white spaces (such as
space and tab), or control characters are permissible.

Always be mindful of your HPGL Controller set-ups, both
system set-ups and CAM set-ups. Develop a consistent strategy of
operation based on shared control between Indexer LPT com-
mands generated by the HPGL Controller on the basis of your
set-ups, and the Indexer LPT commands embedded in the
Command File.

Please also be mindful that while the structure and use of the
Command File introduces a measure of flexibility in the design
of your automated system, it can also be used to inappropriately
bypass some safety features built into the HPGL Controller. If
you do modify or generate a Command File outside of the
HPGL Controller, you must do so only with the proper under-
standing and the utmost care.

Working With Contour Specification Files
The Contour Specification File exists for the purpose of

storing changes that you make to the shape and order of the tool
path contours, as well as additional information relating to offset
compensation. The Contour Specification File is an ASCII file,
very similar to the Command File. However, the Contour
Specification File can contain additional directives relating to
tool path offset. These directives are #DR and #DL.

#DR is similar in meaning to the Command File directive
#D. It indicates a pen down action. However, the #DR directive
also indicates that an offset path to the Right of the contour shall
be traversed. The distance to the right, which is to say, the amount
of right offset compensation, is determined by the value of the
Trace Width (Cutter Diameter) for the current pen.

Page 57HPGL Controller for Windows - Design Reference 

TOOL PATH EDITING Working With Contour Specification Files



#DL functions similarly to #DR, except #DL indicates that
the offset shall be to the Left of the contour.

In the Contour Specification File, #D simply means no off-
set. In this case the path of the tool shall track to the centerline of
the contour.

The actual amount of offset compensation is not stored within
the Contour Specification File. Instead, when the Command
File is over-written from within the Tool Path Editor by means
of the Tool Path Editor’s File > Generate Command File menu,
the actual centerline that the tool path will follow at run time is
calculated from the values set up under the current Pen’s the
Trace Width (Cutter Diameter) setting.

It is important to note that if you change the Trace Width
(Cutter Diameter) field of any of the Pens, you must enter the
Tool Path Editor and over-write the Command File using the
Tool Path Editor’s File > Generate Command File menu before
the Trace Width changes will take effect.

Except for a short header identifying itself, when the
Contour Specification File is first created it is identical to the
Command File. Once the Contour Specification File is created,
the old Command File is obsolete, and must be over-written
before you actually run the job.

Generating a Contour Specification File
If the Contour Specification File does not exist, it will be

generated automatically when you snap over the Edit button from
the Edit > Tool Path dialog. The file name that is in the Contour
Specification File field will be used. If this field is blank, howev-
er, a file name will be constructed using the base name of the
CAM File as a base and “.ctr” as the extension.

When the Contour Specification File is first created the con-
tents of the Command File are copied into it. If the Command
File does not exist, then an empty Contour Specification File is
created. You may graphically add contours using the Tool Path
Editor.

If the Command File field in the Tool Path dialog is empty,
a file name for the Command File will be assigned using the
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base name of the CAM File as a base and “.ixh” as the extension.

Once the Contour Specification File has been created, each
time you enter the Tool Path Editor, the Contour Specification
File will be used and the Command File will be ignored. If you
have made changes from within the Tool Path Editor you must
over-write the Command File using the Tool Path Editor’s File
> Generate Command File menu for these changes to take effect
at run time. If you wish to save changes that you have made to the
Contour Specification File, you may use the Tool Path Editor’s
File > Save menu.

The Tool Path Editor
The Tool Path Editor is entered by snapping over the Edit

button which appears next to the Contour File Specification File
field in the Edit > Tool Path dialog. Information stored in the
Contour Specification File is graphically displayed in the Tool
Path Editor’s window.

Display

We call the succession of commands that describes the tool
path when the tool is engaged (pen down) a “contour”. If the tool
path is not offset, then the actual tool path coincides with the con-
tour. If the tool path is offset, then the contour represents the
desired path of the edge of the tool. Contours are displayed as
solid dark grey lines. Offset paths are displayed as solid red lines.
When there is no offset, the coincident paths of the contour and
the actual tool path appear as solid red lines. Offsets can be
optionally hidden from view for clarity using the View > Hide
Offsets menu.

Optionally, the entire width of the trace of the offset tool path
can be displayed by selecting View > Show Trace Width. The
trace width, which is governed by the current value set up in the
Trace Width (Cutter Diameter) field of the associated Pen
Definitions menu, will appear in light grey.

Over the start point of each contour the Tool Path Editor
displays a small square. A small diamond appears over the end
point. If the contour is closed, which is to say, if the contour ends
over the start point, then that point appears as a diamond drawn

Page 59HPGL Controller for Windows - Design Reference 

TOOL PATH EDITING The Tool Path Editor



within a square.

A point plunge (plunge and retract sequence over a single
point) is also considered a contour. This contour appears as a
small diamond drawn within a square.

We call the path that the tool takes when the tool is retracted
(pen up) a “rapid”. This is because once the tool is retracted it
rapid traverses to the position of the tool plunge associated with
the next contour. Rapids appear on the screen as dark grey dotted
lines. Rapids can be optionally hidden from view for clarity using
the View > Hide Rapids menu.

The Tool Path Editor initially provides for enough room to
display the contours that were saved when the job was loaded.
You may increase the amount of room available using the View >
More Room menu. After this selection you may need to use the
scroll bars to position the area that you are editing within view on
the screen.

Selection

Some editing operations are specific to one contour. Other
operations, such as order arranging and combining, require select-
ing two contours. Two selection types are defined: Select First
and Select Next. You may choose which selection type is active
by snapping over its name in the Edit menu.

You may select a contour by snapping over its start point with
the cursor. When the contour is selected it changes color. Select
First types appear blue. Select Next types appear green. You may
deselect a contour by snapping over its start point a second time.
You may also deselect a contour by selecting another contour.

Alternately, you may use the Tab key on the keyboard to
select and deselect contours. If no contour is selected, then press-
ing the Tab key once will select the first contour in the order of
operation. Pressing the Tab key a second time will deselect the
first contour and select the next in the order of operation.
Successive depression of the Tab key will progress through the
contours in a like manner until the last contour is selected. Once
the last contour is selected, further depression of the Tab key will
have no effect. However, you may select successively backwards
through the order of operation by depressing the Shift key and
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pressing Tab.

Pressing Tab sequentially selects in the order of operation.
Pressing Shift-Tab sequentially selects in the reverse order of
operation.

A contour cannot be deselected unless the selection type is
set to the selected contour type. For example, using the Select
First default setting you may select a contour, which indicates to
you that it’s selection type is “First” by turning blue. Now you
change the default selection type by snapping Edit > Select Next.
A check appears next to that menu, indicating that Select Next is
the new default selection type. Snapping over the start point of an
unselected contour would highlight that contour in green.
However, snapping over the blue (Select First type) contour will
have no effect.

In the same example, if you were using the Tab key to suc-
cessively progress the Select Next contour selection through the
order of contours, it would skip over the contour selected under
the Select First type (it would skip over the blue contour).

Selection of contours using these features is particularly suit-
able for rapid ordering and combining of contours.

Swap Order

The Edit > Swap Order menu selection reverses the opera-
tional order of two contours.

Move to Combine

The Edit > Move to Combine menu selection moves the
contour which was selected under the Select Next type so that its
start point is coincident with the end point of the contour which
was selected under the Select First type. In other words, the con-
tour highlighted in green is always the one that moves. Also
remember that when combining two contours, the Select First
type is always the first in the new order of operation. The retract
cycle of the Select First contour and the plunge cycle of the
Select Next contour is removed, combining the two into a single
contour.
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Connect to Combine

The Edit > Connect to Combine menu causes a straight line
segment to connect the end point of the contour that was selected
under Select First with the start point of the contour that was
selected under Select Next. The retract cycle of the Select First
contour and the plunge cycle of the Select Next contour is
removed, combining the two into a single contour.

Delete First Rapid
Delete Final Rapid

It is sometimes difficult to control the starting position of pen
plotter commands from within a CAD program. Some CAD pro-
grams automatically position the plot to the center of an imagi-
nary page. In a translated plot file this shows up as an undesired
rapid traversal to the starting position at the beginning of the oper-
ation, and also as an undesired rapid at the end. The Edit >
Delete First Rapid and the Edit > Delete Final Rapid menu
selections allow you to conveniently remove these undesired
rapids.

Insert First Rapid
Append Final Rapid

These commands allow you to insert a rapid from the zero
position to the first contour and append a rapid from the last con-
tour back to the zero position. This is particularly useful in jobs
where control of the tool position at the start and finish of a tool
path is essential, such as in Step and Repeat operations.

Delete Selection

The Edit > Delete Selection menu deletes the selected con-
tour. The rapid into the selected contour is automatically connect-
ed to the following contour.

Reverse Direction

The Edit > Reverse Direction menu reverses the direction in
which the selected contour will be traversed. This is particularly
useful in tool offset operations, where you must control which
side of the cutting tool is in contact with the work.
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Move

When you snap over the Edit > Move menu the menu disap-
pears and the cursor appears as a crosshair over the start point of
the selected contour. The X and Y coordinates of the contour will
appear in the lower border of the window. As you move the
mouse, the shape of the contour will follow and the displayed
coordinates will track. If you snap the right mouse button the
operation will be cancelled. If you snap the left mouse button the
contour will be placed at the new position. Don’t worry if you
cannot rapidly place the contour at the exact location that you
desire. After you place the contour in the approximate position
using a left snap, you can bring in a Contour Position control
box using a right snap to more easily locate the contour over the
exact position you desire.

Position

The Contour Position control box can be invoked for a
selected contour by snapping the right button on the mouse or by
selecting Edit > Position. The arrow buttons allow you to move
the contour a step at a time. If you snap over one of the arrows
the contour will move in the associated direction by a distance
corresponding to one step. Holding the mouse button down auto-
matically repeats the operation. As the position of the contour is
moved with the arrow buttons, an outline of the contour at its new
position is shown.

The resolution of the position display is determined by the
system set-up entered in the Setup > X-Y Configuration >
Display Position to __ Decimal Places field. If the display reso-
lution is lower than the step resolution, position changes effected
by the arrow buttons may not be immediately seen.

Alternately, you may type in the new position of the contour
in the X and Y position fields. To view the contour at this revised
position, snap over the Apply button.

To accept the new position snap the Ok button. To abandon
this operation snap Cancel.

Rotate

The Rotate Contour control box can be invoked for a select-
ed contour by means of the Edit > Rotate menu. Buttons on this
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dialog allow you to rapidly rotate the contour around its start
point by incremental amounts. A rotated image of the contour will
appear on the screen.

Alternately, you may type in rotational values into the display
field. Fractional (decimal) amounts of rotation are acceptable. To
view the rotated contour snap over the Apply button.

To accept the rotated contour snap the Ok button. To abandon
this operation snap Cancel. 

Offset Properties

The Offset Properties control box can be invoked for a
selected contour by means of the Edit > Offset Properties menu.
This dialog allows you to designate the type of tool offset as well
as the pen number associated with the contour.

When a Tool Offset type of Left or Right is selected, the
tool offset path associated with the Pen Number immediately
appears on the screen. As mentioned, the amount of offset is
determined by the value of the Trace Width (Cutter Diameter)
field of the Main Menu’s Edit > Pen dialog. If different values of
Trace Width are set up under different pen numbers, you can
view the effect that these different values have on the offset path
by changing pen numbers.

The tool offset path is automatically generated and displayed.
The offset tool path is optimized to avoid undercutting on inside
angles and to avoid excessive tool overshoot on outside angles.
The software does not account for every geometry, such as some
types of cusps, and the software does not automatically flag con-
ditions where the tool is too large. However, by visually inspect-
ing the offset tool path, and by using the View > View Trace
Width option, problems can be identified and corrected. The
Contour Editor, described in the next chapter, will assist you in
interacting with the automatic offset path generator to correct off-
set irregularities should they occur.

Joystick Teach

This this feature allows you use the Joystick Jog feature to
record contours using the carriage of your machine as a guide.
The Joystick Jog feature must be installed for Joystick Teach to
be accessible.
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Segments can be added to any selected contour using the joy-
stick. First select the segment that you wish to modify. If you
want to construct a new contour, first create the contour using the
New Contour selection. Then select Joystick Teach and enter the
teaching mode by simultaneously pressing Mark and Release.

Once in Joystick Teach mode, you can move the carriage
around using the joystick. When you press the Mark button, a tail
segment will be added to connect the previous end of the contour
to the position of the carriage. You may move the carriage over a
contour shape using the joystick, pressing Mark over each point
that you wish to record. When you press Mark, the additional
segment will appear on the screen.

When entering the Joystick Teach mode, the software
assumes that the carriage is located at the end of the selected con-
tour. The next recorded point will be relative to that point. 

You may not be overly concerned about the exact position of
each point. You can always add, remove or adjust the position of
each point later using the Contour Editor. (Enter the Contour
Editor using Edit > Edit Contour Shape). You can even alter-
nate between the Joystick Teach feature and the Contour Editor.
To exit the Joystick Teach mode, simultaneously press Mark and
Release.

New Contour

When you snap over the Edit > New Contour menu a new
contour appears under the cursor. This new contour is a point
plunge, designated by a small diamond surrounded by a square.
You may place this contour in the work area by snapping the left
mouse button, or you may cancel the operation by snapping the
right mouse button. Once placed, the new contour is placed at the
end of the contour list.

Put to File

The Edit > Put to File menu allows you to save the selected
contour to disk as a Single Contour File. Please refer to the
description of the Single Contour File in the chapter entitled
IMPORTANT FILES. You can optionally name this file with
any valid file name that has “.cts” as the extension. However, the
name “instant.cts” is given by default to eliminate typing time for
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contours you may want to temporarily store.

Get from File

The Edit > Get from File menu retrieves individual contours
from Single Contour Files saved on disk. You may select the
contour from the list of files, or accept “instant.cts”, which
appears as the default name to save time when working with con-
tours that are temporarily stored. The head of the retrieved con-
tour appears under the cursor when it is retrieved, and an outline
of the contour appears as you move the cursor for placement.
Snapping the left mouse button places the contour. Snapping the
right mouse button cancels the operation. Once placed, the
retrieved contour is ordered at the end of the contour list.

Edit Contour Shape

Snapping over the Edit > Edit Contour Shape launches the
Contour Editor, which can be used to modify the selected con-
tour. The Contour Editor is described in detail in the following
chapter, entitled CONTOUR EDITING.
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Chapter 9

CONTOUR EDITING

General Description
The Contour Editor is entered from the Tool Path Editor

by selecting the contour that you wish to modify and snapping
over the Edit > Edit Contour Shape menu. The selected contour
is displayed in the Contour Editor’s window.

Similar to the Tool Path Editor, the Contour Editor dis-
plays the contour’s start point as a small square and its end point
as a small diamond. A point plunge, which we have also consid-
ered a type of contour, is displayed as a start point and a superim-
posed end point. Otherwise, the start point and the end point are
connected by one or more line segments. In the Contour Editor
the transition point between segments, which we call a “node”, is
indicated by a smaller square.

We call the last segment in the contour the “tail”. If the end
point of the tail coincides with the start point of the contour we
call the contour “closed”.

You may select a node by positioning the cursor over it and
snapping the left mouse button. You can deselect the node by
either snapping over it once again, or by selecting another node.
When a node is selected, the node and the following segment
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changes color from black to magenta.

Alternately, you may select a node by means of the Tab key
on the keyboard. If no node is selected, pressing Tab once selects
the node associated with the start point. Pressing Tab again
selects the next node in the series of segments. Pressing  Shift-
Tab selects the previous node in the series of segments.

Selection by means of the Tab key is useful to speed editing
operations, especially when nodes are in very close proximity.
Successive selection by means of the Tab key is also useful in
quickly determining the direction of tool motion in a closed con-
tour.

Viewing options in the Contour Editor function similarly to
the viewing options of the Tool Path Editor.

Operations

Add Tail

When you snap over the Edit > Add Tail menu, the cursor
automatically positions itself over the end point of the contour. As
you move the mouse you will see a highlighted segment connect
the end of the previous tail to the end point that you are creating.
The coordinates of the end point of the new tail is tracked in the
lower border of the window. Left snap the mouse to place the end
of the new tail. Right snap to cancel the operation.

Delete Tail

When you snap over the Edit > Delete Tail menu, the tail of
the contour will be removed.

Stretch to Close

When you snap over the Edit > Stretch to Close menu, the
end point of the tail of the contour will be moved to the start point
of the contour.

Add to Close

When you snap over the Edit > Add to Close menu, a tail
will be added connecting the end point of the contour to the start
point of the contour.
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Insert Node

When you snap over the Edit > Insert Node menu, a new
node will be added in the midpoint of the highlighted segment.
The segment associated with the new node will be automatically
selected.

Delete Node

When you snap over Edit > Delete Node the selected node
will be removed, and the previous segment will be stretched to
connect to the subsequent node.

Move Node

When you snap over Edit > Move Node, the cursor will
automatically position itself over the selected node. As you move
the mouse the node and the segments attached to it will follow.
The coordinates of the node are tracked in the lower border of the
window. Left snap the mouse to place the node. Right snap to
cancel the operation.

Position Node

When you snap over Edit > Position Node, or when you
right snap the mouse button, a Position Control dialog appears
on the screen. The Position Control box in the Contour Editor
functions similarly to the one in the Tool Path Editor.

Accept

When you snap over Exit > Accept, the changes that you
have made to the contour are accepted into the Tool Path Editor.

Cancel

When you snap over Exit > Cancel, the changes that you
may have made to the contour are abandoned.
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Chapter 10

PRODUCTION OPERATIONS

This menu provides manual control for tool and workpiece
set-up as well as automatic control for production operations. In a
typical manufacturing cycle, the operator would select a CAM
File using File > Open. Then using selections from the
Production menu, the operator sets up the tool home position
appropriate to the job. Once the proper position of the tool is set
up with regard to the workpiece, automatic operations may be
started.
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Run Tool Path

Danger of Pre-Calculation Dwell

Prior to Indexer LPT version 4, where look-ahead contour-
ing capability was limited to about 125 interpolations, the time to
pre-calculate the largest contour was relatively short. However,
with the introduction of the massive look-ahead capability, the
time to precalculate a large contour can be long enough to deceive
an operator or bystander into thinking that the machine is either
not in operation or malfunctioning. This may be dangerous if
unexpected motion occurs at an inopportune time. Consequently,
in control settings where pre-calculation dwell times may consti-
tute a safety hazard, it is recommended that appropriate measures
be designed into the machine, such as annunciator lights and/or
lock-out mechanisms.

Start

The Run CAM Operation menu selection initiates automatic
tool control. After making this selection, the operator is prompted
for Start (external start switch or Ctrl-F2 depending on Setup
Controls ). Once the Start input is received, automatic tool path
operation commences.

Keyboard Stop

The Keyboard Stop is NOT a reliable method to interupt a
job. In all but the simplest applications the Indexer LPT feedhold
feature must be installed. 

Once automatic tool path operation commences, the HPGL
Controller coordinates control over hardware external to the com-
puter by means of sequential interaction with Indexer LPT.
During the time periods that Indexer LPT has control over the
computer (such as when motors are in motion), the computer’s
mouse and keyboard have no effect. However, during brief peri-
ods of time when control passes from Indexer LPT, such as the
time immediately following the execution of a tool motion and
immediately preceding the next motion, the keyboard can be used
to stop the job. To stop the job from the keyboard, press and hold
the Space key until the machine pauses. When the HPGL
Controller recognizes this input, the job will pause with the tool
retracted. A Pause dialog will pop up, displaying options to con-
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tinue, suspend, or cancel the job.

Feed-hold Stop

Installation of the feed hold feature, as explained in the
Indexer LPT users guide, comprises two external switches: the
feed hold switch, which is typically a normally closed contact to
ground, and the abort switch, which is typically a normally open
pushbutton.  During a Production Run operation, when feed hold
is activated by opening the contacts of the feed hold switch,
motion immediatly decelerates to a controlled stop. All control
activity is suspended as long as feed hold is activated. If feed hold
is deactivated by releasing the feed hold switch, then the job will
resume. However, if contact closure of the abort input is made to
ground via the abort switch, then the tool will be immediately
retracted, and a Pause dialog will be displayed giving the operator
options to continue, to suspend, or to cancel the job.

Back Along Tool Path
This feature is effective when the Contouring feature is

selected and feed hold stop is being utilized. To use this feature,
the operator would have aborted from a feed hold stop by means
of the abort input, and the operator would have selected Suspend
from the Pause dialog that followed. The tool would be in a
retracted position. Two options are available under this menu:

Back to Transition Point

This option allows the operator to retrace the tool path back-
wards (with the tool retracted) one linear segment at a time. Each
time Start is pressed the tool backs up to the start of the preced-
ing segment, thereby allowing for rapid positioning. You may can-
cel out of this control at any time, and select Production >
Resume Job to continue the job.

Back to Last Plunge

This option allows the operator to position the tool at the
point of the previous tool plunge, and to resume the job from
there. 

Head Change
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In multiple head machines it is necessary for the software to
initialize to a “current” Head before automatic operations can
proceed. In the Setup > Multiple Head Configuration dialog,
Head offsets (if any) are specified, as well as lists of Indexer
LPT commands which are used to switch from Head to Head.

If a current Head has not been selected yet, the Head
Change dialog will inform the user that the current Head is not
initialized. In order to initialize to a Head, the user selects the
desired Head by snapping on the appropriate Radio button, and
then snapping on the Ok button. The dialog will respond by ask-
ing for Start to “Move”. (“Move” means move from Head to
Head, which may or may not entail some form of physical
motion).

To remove this dialog after Head selection, snap on the
Cancel button.

When first initializing the Heads, Start causes the command
list for the selected Head to be sent to Indexer LPT. The present
location of the carriage becomes the relative offset of the selected
Head. Subsequent selection of Heads will first move the carriage
to the relative offset position, then send the list of commands
associated with the selected Head to Indexer LPT.

Once a Head is selected, the current Head number is dis-
played  across the bottom of the dialog. Selecting a Head number
equivalent to the current Head will send the command list associ-
ated with the Head to Indexer LPT, but will not cause offset
movement of the carriage, since the carriage is already situated at
the relative offset of the selected Head. This feature is useful in
troubleshooting machine set-ups since it allows the technician to
execute the command list with each Ok - Start sequence.

Jog
This option uses the Indexer LPT joystick control for manu-

ally controlled positioning. The joystick options that are available
to the operator will depend on the options that you include in the
system wiring. Refer to the Indexer LPT documentation to deter-
mine the options which are available.

Since Indexer LPT assumes complete control over the sys-
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tem when in joystick mode, a continuously updated report on
stage position is not possible. To report position, the HPGL
Controller must drop from Indexer LPT joystick mode, read the
positions from Indexer LPT, place position information on the
screen (if the Position box has been activated), then re-enter joy-
stick mode. The switch input entitled Mark is actually the
Indexer LPT joystick “exit” input. The HPGL Controller checks
the input entitled Release whenever Indexer LPT drops from
joystick mode. If Release is active the dialog is removed.

Should the Mark and Release input fail to function, the pro-
gram would not be able to exit from the Jog menu. Consequently,
the HPGL Controller checks for proper operation of these inputs
by requiring the user to activate them to gain entry into the Jog
mode. This is a simple safeguard against a hardware-induced pro-
gram hang.

Move by
This option allows the operator to move the stages by incre-

mental amounts relative to the present position. The contents of
the fields in the dialog box represent the desired motion, and the
check boxes are used to select which axes are to be moved. When
the Ok button is snapped, the distances displayed are rounded off
to the step resolution of the system (The step resolution is the
minimum distance which can be moved, or the distance which is
moved as a result of a single control pulse.) and the user is
prompted for Start. Start will initiate motion. Holding Start will
automatically repeat the motion.

This option does not require position tracking to be initialized
(via the Set Home menu). The field entries are persistent and
remain effective until over-typed by another value. 

This dialog is removed by snapping the Cancel button.

Position to
This selection allows the operator to move the stages to a

designated position relative to the home position. Similar to the
Move by selection, this selection also prompts for Start and dis-
plays the selected values rounded off to the step resolution of the
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system. 

Unlike the Move by dialog, Position to requires position
tracking to have been initialized via the Set Home dialog. The
default values in the fields of the Position to menu represent the
current position, making it easier for the operator to move each
axis individually. To send an axis to its “home” position, simply
enter zero into its associated field by snapping over the Home
button.

This dialog is removed by snapping the Cancel button.

Limit Switch Seek
This menu provides a means for the system to automatically

seek the operational limit switches on each or every axis. The set-
up values in Setup > Limit Switch Seek Configuration governs
the motion during a limit switch seek cycle.

Check boxes select which axes you wish to limit seek. If
more than one axis is chosen, the limit seek sequence will occur
first on the Z axis, followed by the X axis, and finally on the Y
axis.

Snapping on Ok prompts the user for Start. Once the opera-
tor activates Start, the stage will seek its associated limit switch
until contact with the switch is made, or until it has moved the
distance specified in Setup > Stage Configuration >  Total
Distance. If a limit switch closure is not encountered within the
specified distance, the stage will stop and a message will appear.
If the limit switch is contacted, the stage will immediately retract
by the distance specified in Setup > Limit Switch Seek
Configuration > Retract Distance.  Setup > Rapid Traverse
Rates governs the speed of retraction. “Home”, or “zero” position
is automatically set at the final position after retraction. If the
Limit Switch Seek operation fails to find the limit switch,
“Home” position is not automatically set.

This dialog is removed by snapping the Cancel button.

Set Home
Position tracking for any or all axes is initiated by means of
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this menu. The “home” or zero position is set at the present posi-
tion of the selected axis. Position tracking is required for automat-
ic operations.
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Chapter 11

GETTING STARTED

Before Starting
Before starting read and understand the terms and condi-

tions of the Program License Agreement. If you do not agree
with the terms and conditions do not use the software, and
return it to the place of purchase for full credit allowance.

Make an archival copy of the distribution diskette. Keep the
distribution copy in a safe place.

Be sure to read the notes in the README file for important
information regarding the latest software release.

System Set-up
CAUTION

There is no short-cut to getting started. You are the machine
designer. The HPGL Controller can help you automate tool
path control, but you must think through every implication of
your design, especially safety factors. ALWAYS PLAN FOR
THE UNEXPECTED WHEN USING SOFTWARE! Build ade-
quate electrical and mechanical safeguards into your system. If
you think that adequate safeguards are impractical, then do not
use this product!
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You do not need knowledge of computer programming to use
or install the HPGL Controller. You must have a working knowl-
edge of Windows and its file directory structure. You must be able
to copy files, make directories, and specify paths. If you are new
to file this type of  information, one of the best introductory text-
books is Running MSDOS by Van Wolverton (Microsoft Press).

In order to get the HPGL Controller to run, you must have
Indexer LPT installed correctly. Refer to the Indexer LPT man-
ual for installation instructions. You must have a good working
knowledge of Indexer LPT before setting up your machine with
the HPGL Controller. Use the diagnostic program,
IXDIAG.EXE (supplied with Indexer LPT) to exercise and
become familiar with its features.

To copy the HPGL Controller files on to your system, place
the HPGL Controller diskette in drive A, Snap Start >  Run
then type

A:\SETUP

Follow the menus in the SETUP program to install the appro-
priate files on to your hard disk. After running the SETUP pro-
gram, installation of the HPGL Controller is still NOT COM-
PLETE. You must first review every set-up field in every dialog
of the HPGL Controller’s Setup menu, then make an appropriate
CAM File template by reviewing every field in every dialog in
the Edit menu. To make the Setup menu available, run the
HPGL Controller program by double snapping on its icon. To
make the Edit menu available, use File > Open and load the
SAMPLE.CAM file provided.

The best way to get started with this software is to become
familiar with the menu structure and the meanings of all of the
set-ups. Since many of the set-ups are dependent on other set-ups,
there is no quick way to configure a system without learning the
implications of each set-up field. Fortunately, the menus are logi-
cally arranged and easily accessible. This manual is organized
according to the appearance of the menus. A good method of
completing the installation is to systematically review each Setup
dialog, changing parametric set-up values as per the instructions
in this manual.

The initial values which appear in the Setup dialogs are arbi-
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trary. Since each machine design can vary in substantial ways,
and each set-up field can potentially affect others, there are NO
default set-up values. Each and every field must be reviewed by
the designer and replaced by a meaningful value.

After the first change is made, the Setup > Save System
Setup menu becomes available. The first time this selection is
chosen, the HPGL Controller constructs the system setup file
entitled HPIXW.INI, and deposits this file in the WINDOWS
directory.

When changing Setup values you may find the Diagnostic
menu to be very helpful. This menu makes screens available
which give a live display of the state of configured limit and con-
trol switches. Also, it is useful to periodically check the
Diagnostic > Error List dialog, which is included to help you
troubleshoot different kinds of set-up and run-time problems.

If you are unable to get satisfactory results using the built in
diagnostics, run the Indexer LPT diagnostic program,
IXDIAG.EXE, to troubleshoot your system using individual
Indexer LPT commands. (All physical input and output per-
formed by the HPGL Controller goes through the Indexer LPT
device driver).

CAM File Set-up

Making “default” CAM Files

The CAM Files contain information which pertains to the
individual part which is being manufactured. The CAM File not
only contains the file specification of the HPGL File, but also
other vital information necessary in controlling your machine.
Some of this information will change from one job to the next.
Other information will remain the same. For this reason, the
HPGL Controller makes CAM Files easy to change and repli-
cate.

One CAM File is provided on the distribution diskette enti-
tled SAMPLE.CAM. This file must be modified to accommodate
the design of your machine and the type of manufacturing opera-
tions which you are anticipating. After the SAMPLE.CAM file
has been read by means of the File > Open menu, you can modi-
fy it by means of the Edit menus. You can save your modified file
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using File >  Save, or save it under another name (leaving the
original intact) using File > Save As.

Using the Edit menu, you may change set-up values by
means of dialog boxes which are available from each menu selec-
tion. Make sure each set-up is appropriate. When you are finished
editing SAMPLE.CAM, it can be easily saved and/or duplicated
under a different name, such as DEFAULT.CAM. You may wish
to have several “default” CAM Files, one for each general type of
operation which you anticipate. For example, you may have one
CAM File set up with cutting speeds for plastics, another for alu-
minum, steel, etc. Save your files under descriptive names.

As you carefully edit your first “default” CAM File, make
sure that each dialog box has reasonable entries, even if you do
not immediately foresee a use for the particular function. You may
only anticipate using Pen 1. Nonetheless, entries for all pens
should reflect reasonable values, just in case a different pen is
inadvertently called from within a plot file. One strategy is to
assign setup values for unused pens sufficiently slow, so that
machine or tool damage will be avoided. Another strategy is to
make the values of all of the unused pens the same as Pen 1. The
strategy that you adopt will depend on the design of your machine
and the types of operations that you anticipate.

Once you have generated a working set of “default” CAM
Files, setting up a job may be as simple as specifying the Plot
File and, if necessary, adjusting a few other parameters. Then, if
you expect to be manufacturing the same part again at a later
time, you may save the revised CAM set-up under a different file
name, and/or in a different directory.

DO NOT USE SAMPLE.CAM TO SAVE YOUR DEFAULT
SETUPS. SAMPLE.CAM may be overwritten by the installation
SETUP program, should you need to re-install the software, or
when you perform subsequent upgrades. CAM Files that you cre-
ate, as well as other files that are not part of the initial installation,
will not be automatically removed by the installation SETUP pro-
gram during the de-installation procedure, nor overwritten during
upgrades.

Making Working CAM Files from “defaults”

Assuming you have created a CAM File with the most com-

Page 82 HPGL Controller for Windows - Design Reference 

CAM File Set-up GETTING STARTED



mon settings, you may follow these simple steps to generate
working CAM Files. Let us assume that you have named this
CAM File DEFAULT.CAM  Also, for the sake of an example, let
us assume that you will be using the plot file included on the dis-
tribution diskette entitled 123 sample.plt

1) First load DEFAULT.CAM using File > Open.

2) Using File > Save as, generate a CAM File entitled
MYJOB.CAM by typing MYJOB in the dialog field when
prompted.

3) Follow the recommendations from the dialog prompts that
pop up until you are no longer prompted. Notice that
“MYJOB.CAM” now appears in the title bar at the top of the win-
dow frame.

4) Use Edit > Tool Path to bring in the Tool Path dialog.
Use the Browse control associated with the HPGL File field to
enter the plot file name. Locate the desired plot file (123 sam-
ple.plt ) and double snap over it to transfer its name into the
HPGL File field. Snap Ok to accept the settings and to leave the
Tool Path dialog

5) From the Main Menu, use Edit > Translate Plot File to
generate an initial Command File.

6) Select Yes from the dialog prompt that follows to view an
image of the tool path from withing the Tool Path Editor. If you
edit the Tool Path, you can overwrite the Command File from
within the Tool Path Editor.

7) You may wish to make changes appropriate to the job
using the Edit Menu - changes such as cutting speeds, tool off-
sets etc.

8) Your job is now ready to run.

Use Caution when Naming Command Files

If you follow the method of generating working CAM Files
that was outlined in the previous section, the Command File
associated with each job will be automatically named according to
the root name of the CAM File. However, is possible to specify
the same Command File name in different CAM Files. This can
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be very useful. Suppose you are manufacturing a particular part
from different materials. The Command File will be the same,
but the tool speeds may vary according to the material being used.
In this case you simply set up the different pen speeds different
under CAM Files , but keep the Command File specification the
same. You are at liberty to change other CAM set-ups as well:
plunge depth, tool passes, offsets, etc. without needing a separate
identical Command File for each CAM file.

This flexibility introduces a possibility for error, since
changes which affect the generation of the Command File, such
as changes to the HPGL File, or changes to Scaling, will affect
all CAM files which specify the same Command file name.
Consequently, in most applications it is desirable to give the
Command File a unique name. It is recommended that the name
of the Command File reflect the base name of the CAM File,
only with “IXH” as the extension. As mentioned, are given an
option to have this done for you automatically when you replicate
a CAM File using File > Save As.

Working with Plot Files
The HPGL Controller is written to accept a subset of the

HPGL command set for the HP 7475 plotter. Since most CAD
programs utilize only a subset of the HPGL command syntax, you
may find that a variety of HP plotter drivers will generate files
which can be used successfully. Since there are many different
types of HP plotters and numerous CAD programs, it is impracti-
cal to deal with each in detail here. Here are some simple guide-
lines to help you develop a procedure to accommodate your oper-
ations.

At first some amount of experimentation is necessary to learn
the peculiarities of the Plot Files that your CAD program gener-
ates. For example, some CAD programs limit the size of the plot
when specifying the HP7475. In this case you must experiment
with other plotter setups until a suitable one is found.

Some CAD programs begin the plot in the center of the page.
Others begin at a “home” reference point. Others allow you to
choose. Beginning with a “home” reference point is easiest. Start
out with simple experimental tool paths to determine how your
CAD program begins the plot, then use the HPGL Controller
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set-ups and features to develop a job setup procedure.

View Your Work
View > Distance can be helpful in estimating the time that it

will take to run the job. The Distance dialog shows the accumu-
lated traversal distances for each pen, as well as the accumulated
rapid traversal distance. 

Use View > Toolpath Preview to view the tool path defined
by the Command File. The tool path is shown in a solid line in
places where the pen is extended (down or “plunged”), and in a
dotted line where the pen is retracted (up). If a Production >
Limit Switch Seek operation has been performed on the X and Y
axes, then a box representing the area surrounded by the limit
switch positions is shown in dashed lines. The limit switch delim-
ited area will only be shown if a Production > Limit Switch
Seek sequence has been performed. 

View > Carriage Preview is similar to View > Toolpath
Preview, except that it shows motion of the tool carriage consid-
ering Head Offsets. If your set-up only uses one Head, or if the
values of the Head Offsets are all zero, then both Toolpath and
Carriage Preview operations will display the same graphic.

Note that the Preview selections operate only on the
Command File and NOT on the any of the other files associated
with the job..

Also note that you may overlay the Preview of one
Command File over another. This is useful in manufacturing
operations where two or more CAM operations are performed on
the same part piece. Be careful, however, because this feature also
makes it possible to view one Command File while another is
loaded. It is always wise to clear the screen using View > Clear
View, and view the current CAM set-up using View > Toolpath
Preview before running a job.

The Toolpath Preview feature is especially convenient when
setting up for Step and Repeat. Graphics are drawn in designated
positions relative to each step and repeat operation, and in the
order in which the tool will follow. The time which is required for
the Preview operation depends on the complexity of the graphic.
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If you wish to abort the operation, press the Space key at any
time.

The job cannot be run unless the home positions are set. The
Production > Limit Switch Seek operation automatically sets the
home positions after it completes its task. You can re-position the
home position by first moving the carriage via the Production >
Jog, Production > Move by or Production Position to menus,
and then setting the new home reference using the Production >
Set Home menu. After you have relocated the home positions,
you may once again preview the tool path in relation to the limit
boundaries.

Having conveniently placed to tool in the starting position
use Production > Run to run the job!
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